Routine Checklist for Pedal problems/diagnosis

alanfc

Senior Member
Joined
Jan 2, 2008
Messages
170
Reaction score
12
Can anyone help me build a list, or lead me to one? I think it would include tips on:

1-open the back, clean the contacts/jack thingie?
2- how do we see if a knob/pot is bad
3- how do we see if the footswitch/button is bad
4-how do we see if a toggle switch has gone bad

(can you =see= these things?) :confused:

(I have a Guyatone Flanger that started acting weird ..when I punched it didn't do anything, then when touching one of the =knobs= it made a crackle and started working..jack wiggling had no bad effect. I know there were a few times I may have been rough on the stompage since the controls had shifted, not gently- but by heavy foot)

thank you !
 

lp59aholicDon

V.I.P. Member
V.I.P. Member
Joined
Aug 20, 2007
Messages
5,206
Reaction score
61
Unless the battery erupted, or the contacts on the battery connector got soaked in some other kind of gooey stuff, they should be fine,
you cant see if knobs are bad, but spraying with contact cleaner from Radio shack may tell you if they are dirty, if a switch is dirty it wont normally show, another place you can spray contact cleaner, same with stomp switches, Pots making snap crackle pops might be contacting something they should not be , and grounding out on the housing or other part
If the footswitch is bad, it will just cease working , IF contact cleaner doesnt do anything for any of the things you listed, repair or replace the pedal

Can anyone help me build a list, or lead me to one? I think it would include tips on:

1-open the back, clean the contacts/jack thingie?
2- how do we see if a knob/pot is bad
3- how do we see if the footswitch/button is bad
4-how do we see if a toggle switch has gone bad

(can you =see= these things?) :confused:

(I have a Guyatone Flanger that started acting weird ..when I punched it didn't do anything, then when touching one of the =knobs= it made a crackle and started working..jack wiggling had no bad effect. I know there were a few times I may have been rough on the stompage since the controls had shifted, not gently- but by heavy foot)

thank you !
 

drewbertca

V.I.P. Member
Joined
Dec 6, 2007
Messages
2,506
Reaction score
18
It could also be a bad (worn) solder joint on the pot that crackles.....less likely but possible
 

drewbertca

V.I.P. Member
Joined
Dec 6, 2007
Messages
2,506
Reaction score
18
I use a lubricating control cleaner....I find WD-40 destroys some materials....the cleaner/lubricant is expensive but is also usefull for cleaning the hinge/joing of my Wah-Wah....it used to squeak when I used it...at practicing level I could hear it over my amp....annoying.
 

alanfc

Senior Member
Joined
Jan 2, 2008
Messages
170
Reaction score
12
For what? lol
I'm a little old fashioned I guess



See everytime I get a crackle or a sputter out of one of my pedals I take it off the board and put it in the closet. I use a PP2 so batteries and batt. clips aren't my problem. I've got 2 delays, one flanger, one chorus, one phaser,,,all in the closet. I would love to open them up and fix them myself. I'm semi-competent in the tiny arts of guitarism (soldering and wiring, and un-soldering and re-wiring :rofl: )

Wanna save a little money here for other things like a......DMM

:naughty:
http://www.legendarytones.com/EHDMM.jpg
 

drewbertca

V.I.P. Member
Joined
Dec 6, 2007
Messages
2,506
Reaction score
18
I was confused by the "thank you"...I wasn't trying to be upsetting or mean....I'm a graduate of an electro-technology program so I have a little knowledge of my effects circuitry....I understand the frustration when one stops working....I had a digital delay that looked fine but the IC failed internally so I couldn't troubleshoot it....I apologize if I seemed rude.....I hope it's something simple with the pots being dirty, or simply a loose connection...and sorry again for my apparent rudeness.....i honestly feel bad...
 

alanfc

Senior Member
Joined
Jan 2, 2008
Messages
170
Reaction score
12
I was confused by the "thank you"...I wasn't trying to be upsetting or mean....I'm a graduate of an electro-technology program so I have a little knowledge of my effects circuitry....I understand the frustration when one stops working....I had a digital delay that looked fine but the IC failed internally so I couldn't troubleshoot it....I apologize if I seemed rude.....I hope it's something simple with the pots being dirty, or simply a loose connection...and sorry again for my apparent rudeness.....i honestly feel bad...
No no not even... no offense taken really. Thanks
 

drewbertca

V.I.P. Member
Joined
Dec 6, 2007
Messages
2,506
Reaction score
18
I think this may be another thread officially killed by yours truly
 


Latest Threads



Top