Issue on my Laney IRT Studio !!

Mockbel

Senior Member
Joined
Nov 2, 2015
Messages
3,825
Reaction score
5,056
Hello

I am back to use the preamp section of my Laney IRT Studio after may be a couple of years of using it as a power amp only (plug the pedalboard to the Return of the FX Loop)..

For those who are not familiar with this amp, it has 3 channels: Clean, Rhythm, and Lead

Clean and Rhythm channels are working perfectly but the Lead channel has a very low volume.. I need to turn it to max just to match level 3 of the Rhythm channel volume which is definitely abnormal… Lead channel should actually have more gain than Rhythm channel.

I tried both 1W and 15W inputs… I gave the gain and volume pots some cleaning spray but zero effect on the issue.

What can be the root cause of it if anyone can help ??
 

Attachments

  • 0DF1BC30-ECA9-4C6B-91AD-9AC2A4F3E484.jpeg
    0DF1BC30-ECA9-4C6B-91AD-9AC2A4F3E484.jpeg
    129.9 KB · Views: 10

CB91710

Not Michael Sankar
Double Platinum Supporting Member
Joined
Jul 19, 2019
Messages
15,802
Reaction score
46,236
Swap in a spare tube for V1... or swap V1 and V2 and see if the problem moves to all channels.
Tube could have gone bad over the years.
 

Mockbel

Senior Member
Joined
Nov 2, 2015
Messages
3,825
Reaction score
5,056
Swap in a spare tube for V1... or swap V1 and V2 and see if the problem moves to all channels.
Tube could have gone bad over the years.
I have already replaced a tube last year.. but symptoms were different.. volume was keeping going up and down and replacing a tube resolved it.. I will give it a try anyway.. so I have more than 15 screws to unscrew now.. damn for that so bad case design !
 

cybermgk

“No such thing as fun for the whole family"
Gold Supporting Member
V.I.P. Member
Joined
Jul 7, 2011
Messages
16,672
Reaction score
25,679
Swap in a spare tube for V1... or swap V1 and V2 and see if the problem moves to all channels.
Tube could have gone bad over the years.
My suggestion as well. With 3 preamp tubes, I'd bet the Lead stage uses a half of a tube, the others don't, and it's failing, or just bad. If I were to guess it would be V3. But, that is a pure guess. Best option, is to take a known good tube and try it in each spot..
 

Latest Threads



Top