Buttons nonfunctional on Roland VS-1680

KA9INV

Member
Joined
Nov 17, 2010
Messages
38
Reaction score
79
Hi all. I picked up a Roland VS-1680 right after Christmas for $60. The seller claimed to have gotten it from an auction and had no idea how to operate it other than to know it powers up. Well, it turns out a bunch of the buttons on this unit don't function at all, right down to the play, stop, and record buttons. Has anybody else had this trouble with a Roland unit, and how do you fix it? I know, I know, for a mere $60 I should have seen this coming...
 

Zungle

Senior Member
Joined
Aug 21, 2014
Messages
5,998
Reaction score
10,465
Hi all. I picked up a Roland VS-1680 right after Christmas for $60. The seller claimed to have gotten it from an auction and had no idea how to operate it other than to know it powers up. Well, it turns out a bunch of the buttons on this unit don't function at all, right down to the play, stop, and record buttons. Has anybody else had this trouble with a Roland unit, and how do you fix it? I know, I know, for a mere $60 I should have seen this coming...
Some ideas....no specific order


1. If possible re-initialize /reset unit......

2. contact Roland and see if that unit is still serviceable

3. Find a user group see if they have any info on that issue.

4. Find manual read thru trouble shooting section

5. Re-Sell it as non functioning for parts...start over.
 

none2low

Senior Member
Joined
Nov 13, 2012
Messages
372
Reaction score
368
I would definitely start with the suggestion of trying a full factory reset to see if that makes a difference.

If not, check to see if the unit is firmware upgradeable. Flashing the firmware might resolve the issue in short order if it's software related, otherwise if the actual switches have gone out you'll need to open it up and see if you can find suitable replacements.

Whether all of this is worth your time and effort only you can decide.
 


Latest Threads



Top