Recent content by torqvaw

  1. T

    Is a Lifeson noisier than a non a non piezo lp?

    What type of noise are you referring too? Pops and/or other sounds of electrical interference, or something else? My Lifeson is much more prone to interference from other sources than any other guitar that I have. It also has a low level "hiss" that comes from the amp on the Graphtech board...
  2. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    One more thing I forgot to mention... I was in another guitar center about a week ago and they had another lifeson. I thought what the heck I fired it up and channel 3a was very muted. I talked to the sales guy and he said it just came back in from getting serviced. Lol. I would guess it...
  3. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    I don't think that is the same unit unless they had it shipped from the rockville, md store in the past week or two. I don't remember the digit before 79 but I believe it was a 6. If I were you I would save yourself the headaches and just return it. I believe they must have had a bad run...
  4. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    I returned mine Friday night. Do you know how old your Triamp was?
  5. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    Thanks, didn't realize that.
  6. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    Not good. What type of issue are you having? Looking to PM you but it does not appear I have the feature.
  7. T

    Hughes and Kettner Triamp MKII-Question for owners of this amp

    I also have a question for Triamp owners. About 2 months ago I went into a Guitar Center and saw a new Lifeson triamp. Was blown away as I thought all of these were long gone. Sat down and started playing it on channel 2a and after about 10 minutes noticed that it started to sound very...
  8. T

    New Lifeson Axcess is noisy

    Randy, Have you resolved your issue? I also have an AL and am having the exact same issue. I actually thought I had a tube going bad opn my head. Tons of hiss even with the volume completely off on the guitar. Plugged in another guitar and completely quiet.

Latest Threads



Top